Wednesday, November 29, 2023 β€’ Welcome to the πŸ’― Nonsense-Free Zone!
πŸ›οΈ Check out Today’s πŸ”₯Amazon logoDeals! πŸ›’

DS1821+ NAS Review (vs DS1621+): Tips on Synology 10Gbps and RAM Upgrades

Share what you're reading!

As the name suggests, the Synology DS1821+ is of yesteryear.

It's even older than that -- Synology first announced it in 2020. But it's still going to be the latest Synology 8-bay NAS for homes and SMBs for a while -- Synology likely won't release its replacement this year.

What's most notable, though, is that it's basically the DS1621+ plus two drive bays. The two share the same hardware specs -- both are the firsts from Synology that use an AMD Ryzen quad-core CPU.

That said, this is not a review of the DS1821+ -- you should check out that of the DS1621+. Instead, I'll mention how to get the most out of this server -- or the DS1621+ -- via hardware upgrades.

In a way, this post is about Synology hardware upgrades, specifically in RAM, storage, and 10Gbps network speed. In other words, if you're looking for the best 10Gbps NAS for the home (or small office), you're at the right place.

I wrote this post based on my own experience. After using the DS1621+ for over a year, I recently got a DS1821+, not as a replacement. I like both servers equally.

Synology DS1821 vs DS1621
Synology DS1821+ vs DS1621+: Stretch the latter out to add two more drive bays, and you'll get yourself the former.

Synology DS1821+ vs DS1621+: It’s 8 vs 6 in the number of drive bays

Right off the bat, it's worth noting that the DS1821+'s extra two drive bays will come in handy for those needing to add more storage space without getting an expansion unit.

The 5-bay DX517 expansion unit uses an eSATA connection, which caps at 5Gbps, to connect to the server.

The next generation of Synology expansion hardware, the DX1222, has a much faster backbone connection -- up to 24Gbps via a Mini-SAS HD port -- but is only available in more expensive servers, starting with the DS2422+.

With either, you'll have to deal with an extra hardware box and more wires.

Considering you can find hard drives of 20TB and higher capacities nowadays, the number of drive bays is not that important. So, if one can live with fewer bays, the DS1821+ has nothing to justify the more expensive cost compared to the DS1621+.

If you're mulling over the two, that is the only point you should consider.

Synology DS1821+ vs DS1621+: Hardware specifications

ModelDS1821+DS1621+
CPUAMD RyzenV1500B 
quad-core 2.2 GHz
AMD RyzenV1500B 
quad-core 2.2 GHz
System Memory4 GB DDR4 4 GB DDR4 
Max Memory32 GB 
(16 GB x 2 slots)
32 GB 
(16 GB x 2 slots)
Dimensions6.53 x 13.5 x 9.57 in
 (166 x 343 x 243 mm)
6.53 x 11.1 x 9.57 in
 (166 x 282 x 243 mm)
Weight13.23 lbs (6.0 kg)11.24 lbs (5.1 kg)
Drive Bays86
Expansion SupportYes 
(two units)
Yes 
(two units)
Drive Interface2.5 or 3.5 SATA Drives, 
Hot-swappable
2.5 or 3.5 SATA Drives, 
Hot-swappable
Maximum Capacity
(at launch)
128TB 
(8x 16TB drives)
96 TB 
(6x 16TB drives)
Built-in M.2 SlotsTwoTwo
RAID TypesSHR, Basic, JBOD,
RAID 0, RAID 1, RAID 5, 
RAID 6, RAID 10
SHR, Basic, JBOD,
RAID 0, RAID 1, RAID 5, 
RAID 6, RAID 10
Ports / Interfaces4x RJ-45 1GbE LAN,
 3x USB 3.0, 
2x eSATA
4x RJ-45 1GbE LAN,
 3x USB 3.0, 
2x eSATA
PCIe Expansion1x Gen 3 x8 PCIe slot1x Gen 3 x8 PCIe slot
Add-in-card Support 
(not included)
10GbE Add-on NIC card: 
E10G18-T2
E10G18-T1
E10G21-F2
10GbE Add-on NIC card: 
E10G18-T2
E10G18-T1
E10G17-F2
Operating SystemDSM 6 (and later)DSM 6 (and later)
File System 
(Internal / External)
Btrfs, EXT4 / 
Btrfs, EXT4, 
EXT3, FAT, 
NTFS, HFS+, 
exFAT (app required)
Btrfs, EXT4 / 
Btrfs, EXT4, 
EXT3, FAT, 
NTFS, HFS+, 
exFAT (app required)
Suggested Retail Price
(at launch)
$949.99$799.99
Warranty3 years3 years
Hardware specifications: Synology DS1821+ vs DS1621+

Synology DS1821+ vs DS1621+: Hardware upgrades are (almost) a must

As you'll note in the table above, both servers come with a powerful CPU yet just 4GB of RAM.

That amount is enough for general usage, but a memory upgrade is a must if you want to get the most out of the server.

Synology DS1821
Synology hardware upgrades: Here's my new Synology DS1821+ and the upgrade parts, including a 10Gbps PCIe add-on card, a 32GB DDR4 RAM kit, and two 1.92GB Seagate IronWolf NVMe SSDs.

What's more, each server has two built-in M.2 slots to host two NVMe SSDs -- a good upgrade option if you use the server for applications that can benefit from caching. There's no way to use these slots for general storage.

And finally, the servers have a PCIe slot for an add-on card. In this case, you can use it to add 10Gbps connectivity to the servers -- another must if you're into Multi-Gig.

With that, let's proceed with the upgrade. For this post, I did the upgrades on a DS1821+, but the processes and parts are the same on a DS1621+.

Synology DS1821+: RAM upgrade

The server uses DDR4-2666 PC4-21300 ECC SODIMM RAM and can handle two sticks.

Synology says the DS1821+ supports a maximum of 32GB, but I suspect you can double that by using two 32GB sticks. In any case, 32GB is probably all you'd need anyway.

Synology DS1821
Synology hardware upgrades: Here's my Synology DS1821+ with two new 16GB sticks of NEMIX RAM. Note the original 4GB stick, which you can use for a different server.

Synology is stringent in RAM support, and most standard third-party RAM won't work. It's somewhat of a ploy to force users into using its prohibitively expensive RAM -- a 16GB Synology stick currently costs $350.

That said, I'd recommend this 32GB kit from NEMIX RAM for less than $200. It's a great deal and has been working well in my case.

Note that you don't need to use both RAM slots, nor do you need to use same-size sticks -- you can mix two sticks of different sizes or even brands.

For example, one 16GB NEMIX stick plus the 4GB stock RAM will give your server 20GB in total system memory.

DS1821 Info
My DS1821+ has been running happily with 32GB of NEMIX RAM.

After that, you can install them via the slot on the server's underside. The process is easy and painless. All you need is a small Philip-head screwdriver.

Synology DS1821+: SSD caching upgrade

As I mentioned in the review of the DS1621+, in most cases, SSD caching upgrade is unnecessary and won't increase the server's general copy speeds.

However, if you use your server to host a large database, a website, or any applications that benefit from caching, the two M.2 slots will come in handy.

You will need two drives if you want to cache for both writing and reading -- so it's a good idea to get two.

By the way, you should only cache a hard drive volume. If you use SATA SSDs for storage, caching is unnecessary. On top of that, if you decide to cache, it's also a better idea to upgrade the server's network to 10Gbps -- more below -- or at least use its Link Aggregation feature to get a 2Gbps connection out of its two Gigabit ports.

The more is always, the better in terms of capacity, but generally, you won't need drives larger than 250GB for caching.

However, the appropriate caching size depends on the server's storage volume that you want to cache. The Storage Manager app's SSD Cache Adviser function will give you a good idea of the cache size.

When in doubt, get two large drives. In my case, I used two 1.92TB Seagate IronWolf drives, which are designed for NAS servers. You can use general non-NAS SSDs, but they might have less-than-desirable endurance ratings for the task.

Synology DS1821
Synology hardware upgrades: The Synology DS1821+'s M.2 slots are on its left inner wall.

In any case, installing the SSDs onto the server is super easy. The two M.2 slots are inside the server's left wall. Take the first and second drive bays out, and you can reach them.

Synology DS1821+: 10Gbps NIC card upgrade

This part requires the most work -- you have to remove the server's cover. However, it's still easy enough.

Synology DS1821+ PCieSynology DS1821+
Synology DS1821+ 10Gbps upgrade: It's a relatively straightforward process.

Use a screwdriver to undo the six screws on the back that hold the server's top cover -- you can easily identify them -- then remove the cover. Now install the card on the PCIe slot and put the cover back. Mission accomplished.

The harder question might be which card to get. Generally, you have three options:

  1. E10G18-T2: Dual 10Gbps RJ45 Multi-Gig ports.
  2. E10G18-T1: Single 10Gbps RJ45 Multi-Gig port.
  3. E10G21-F2: Dual 10Gbps SFP+ ports.

The second option is the least expensive but is good enough for most cases.

Synology DS1821 vs DS1621
Synology DS1821+ vs DS1621+: Here are my servers upgraded to 10Gbps using two different dual PCIe cards.

For my case, though, I used the first option for my DS1821+ and the third for my DS1621+ -- two ports are always better than one. But no matter which card you get, the installation is the same.

Extra: Synology DS1621+ to DS1821+ in-place upgrade

If you're using the DS1621+ and want to upgrade to the DS1821+ to take advantage of the two extra drive bays, the process is the same as when you migrate from one Synology server to another.

Specifically, move drives from the former to the latter, and everything will be there after you re-install DSM.

DS1621 StorageDS1821 Storage
Synology DS1821+ vs DS1621 (left): The Storage Manager of the servers before and after an in-place upgrade using the same drives. Note the empty drive bays.

And that worked with all the upgrades, too. In my case, I tried the migration with all the parts mentioned above installed on the DS1621+ then moved them, together with the hard drives, to the DS1821+.

After the DSM re-install process, which took about 10 minutes, all of the settings, including the caching, of the DS1621+ were ported over to the DS1821+ with no issue.

By the way, the DS1821+ delivered the same performance as the DS1621+ in my testing. That was expected, considering they shared the same hardware specs (and upgrades).

Again, the difference between these two is just the extra two drive bays of the DS1821+, and all that implies.

Synology DiskStation DS1821+'s Rating

9 out of 10
Synology DS1821
Performance
9 out of 10
Features
9.5 out of 10
Design and Setup
9 out of 10
Value
8.5 out of 10

Pros

Powerful AMD CPU delivers fast and reliable performance

Robust DiskStation Operating System with tons of practical home and business applications, including Virtual Machines

Straightforward and consistent setup, upgrade, and management

Built-in M.2 NVMe slots

Eight built-in drive bays, lots of network storage options

Quiet operator

Cons

Expensive RAM upgrade

No built-in 10Gbps port (adapter required)

Only two camera licenses included

A bit pricey

Synology DS1821+ vs DS1621+: Which to get

Both the DS1821+ and DS1621+ are excellent servers. They are essentially the same, except the former has two more built-in drive bays.

And that difference can be a huge deal if you want a ton of extra storage space or just more volumes or RAID configurations. In this case, the cost difference between the two is lower than getting an expansion unit.

If six bays are enough for you -- they are plenty for most users considering you can get hard drives of very high capacities these days -- the DS1821+ doesn't offer anything extra.

On the other hand, getting the hardware upgrades in RAM and 10Gbps connectivity is recommended no matter which server you end up getting. In fact, in my experience, the memory upgrade is the minimum requirement if you want to enjoy your NAS machine to the max.

Share what you just read!

Comments are subject to approval, redaction, or removal.

It's generally faster to get answers via site/page search. Your question/comment is one of many Dong Knows Tech receives daily. Β 

  1. Strictly no bigotry, profanity, trolling, violence, or spamming, including unsolicited bashing/praising/plugging a product, a brand, a piece of content, a webpage, or a person (β€’).
  2. You're presumed and expected to have read this page in its entirety, including related posts and links in previous comments -- questions already addressed will likely be ignored.
  3. Be reasonable, attentive, and respectful! (No typo-laden, broken-thought, or cryptic comments, please!)

Thank you!

(β€’) If you represent a company/product mentioned here, please use the contact page or a PR channel.

22 thoughts on “DS1821+ NAS Review (vs DS1621+): Tips on Synology 10Gbps and RAM Upgrades”

Hate scrolling? Consider subscribing!
  1. I’ve read a lot of reviews and have researched the next level of NAS. I’ve had two Thecus NAS’s over time (N7700SAS with seven 2TB SAS drives that STILL works; and a 5550 with 5 drives that’s been rock solid).

    Looking at the Synology DS1821+
    – Eight Seagate Exos x20 20TB ST20000NM007D hard drives
    – Nemix 64GB kit (2x32GB) DDR4-2666 PC4-21300 ECC Sodimm
    – Team Group T-FORCE CARDEA A440 PRO M.2 2280 2TB PCIe Gen4 x4

    At RAID5 the 8 drives will give me 140TB of storage (120TB at RAID6–which I might consider).

    Reply
  2. Can you advise on the operational noise level of each? The 1621 uses 92mm fans, while the 1821 uses 120mm fans. In theory, the larger fans should generate more air flow with less overall noise. Sadly Synology doesn’t post dB ratings for the units, and I need a quiet one for my home office….

    Reply
    • Generally, Bill, there’s no need to worry about the fans’ noise in Synology servers. They are quiet and you can control their speeds, too. What you might want to consider is the noise of the hard drives. And that varies. But it’s never good to put a NAS in your bedroom.

      Reply
      • Dong, I recently bought the 1821+ and filled it with 2.5 SSDs. I’m quite surprised how loud the fans are even on quiet mode. I was planning on keeping it in corner of my office but the fans are very audible. Since you mention the 1821+ is quiet, I’m wondering if maybe there’s a problem with my fans (I bought it open box). The 1821+ with SSDs is louder than my old 4 bay with spinning drives. Not sure how accurate it is but my phone measures around 50 dB holding right above the back, around 39 dB for my old in the same position. Thanks

        Reply
        • I’ve used this 1821+ since the review, TC. and it’s been quiet. But, that depends on your expectations, it’s not silent.

          Reply
        • I took the leap and jumped on the DS1821+, loaded with 32GB RAM, 2 1TB M2 drives, and 5 Seagate 12TB Iron Wolf drives. It is quiet enough for our use, and I had no issues with running it in on my workbench (just 6 feet from my desk) the last few days. When you fist power on, do you hear the fans run fast for a bit, then slow down? If not, someone may have changed the configuration settings on your unit; change the fan back to “Quiet” mode.

          Reply
          • Thanks for your comment Bill. It was indeed set to quiet mode. The noise issue turned out to be from a faulty PSU fan. Synology sent me a replacement and it’s much better. I also decided to replace the stock fans with Noctua fans. Can still hear the PSU fan on the replacement, but if standing 6 feet away it is completely quiet now.

  3. That is a great review!
    I have a DS1821+ and consider buying another one for backup/media. After reading your post I’m considering a DS1816+ instead as I’ll buy 3x18TB disks for my new nas. My current setup has 8x4TB.

    Also with the memory upgrade. Do you get the warning message that non-compatible memory is found in the system? What about memory test?

    Reply
    • Not with the memory I used, Tommy, so you can get the same. It’s been stable since I posted the review. Good luck!

      Reply
      • Hey Doug, and first –thank you– your info is great.

        I just got emailed notification of this post today 20230527 so *cough* sorry for being late to the party.

        – I stuck with Synology and DSM. The only thing I converted to ext4 was the USB backup hdd I use just in case.
        – I’ve integrated no apps other than USB automated backup, so it’s strictly being used as a NAS.
        – The scope of the work is to make uptime be 100% not 5 nines not 4 nines, a real 100%. The Synology server is doing that. The “oh shit” strategy is to use the USB drive on the master server, and that is a smallish linux PC with a backup cold one ready to go in the same rack above it.

        I appreciate your advice and you did help me (almost) a year ago when you said to stick with DSM. I did. Happy I did.

        Again, thank you. Sorry I can’t read your website directly… you have a problem with my ad blocker. Fundamentally I’d love to support you and your site and not disable ad blocker nor see ads. If there’s such an option I look forward to being educated about it…

        Ehud
        Tucson
        Arizona
        US
        North America
        SOL-3
        Milky-Way-1

        Reply
          • Dong, I apologize. Like you, I’m sensitive to English-grammar corrections that change my name. I am responsible for my words, so I clicked “send” and had your name wrong — my bad!

            Will check out the sub option shortly. The apology needed to come first πŸ™‚

            E
            P.S. If you know someone who wants to wrestle with Xfinity over IPV6… I have a gig I’m tired of pursuing (my house).

          • No worries. You can turn IPv6 off at the router. There’s no need for it locally. You can also do that on a Xfinity gateway for the LAN side (if it’s required for the WAN side), or on each device individually.

          • Subscribed.
            So on the Xfinity/Comcast IPv6 thing. Before three days ago when “they changed things” during an 0200-0430MST (local) outage… IPv6 worked.
            Now it gives me an address, and a gateway, but the gateway is not reachable and the default route –if accepted– isn’t either. I don’t want to call them. They are bloodsucking turds. I’d rather pay someone else to do it πŸ™‚
            E
            gavron@EhudGW1] /ipv6> /ipv6
            [gavron@EhudGW1] /ipv6> export
            # may/27/2023 17:17:44 by RouterOS 7.9rc1
            # software id = 7M3Q-07G6
            #
            # model = RB2011UAS-2HnD
            # serial number = 419F02EDEFC7
            /ipv6 dhcp-client
            add add-default-route=yes default-route-distance=10 interface=E04-Xfinity pool-name=comcast6 request=address
            /ipv6 firewall filter
            add chain=input protocol=icmpv6
            add chain=input connection-state=established,related
            /ipv6 nd
            set [ find default=yes ] interface=bridge-vlan1
            /ipv6 settings
            set max-neighbor-entries=1024
            [gavron@EhudGW1] /ipv6> address print
            Flags: D – DYNAMIC; G, L – LINK-LOCAL
            Columns: ADDRESS, INTERFACE, ADVERTISE
            # ADDRESS INTERFACE ADVERTISE
            0 DL fe80::d6ca:6dff:fe84:fe59/64 bridge-vlan1 no
            1 DL fe80::d6ca:6dff:fe84:fe5c/64 E04-Xfinity no
            2 DG 2001:558:6034:e:8424:deee:f96a:cdbb/128 E04-Xfinity no
            [gavron@EhudGW1] /ipv6> route print
            Flags: D – DYNAMIC; I, A – ACTIVE; c, d, y – BGP-MPLS-VPN; H – HW-OFFLOADED
            Columns: DST-ADDRESS, GATEWAY, DISTANCE
            DST-ADDRESS GATEWAY DISTANCE
            DIdH ::/0 2001:558:4043:16::10 10
            DAc 2001:558:6034:e:8424:deee:f96a:cdbb/128 E04-Xfinity 0
            DAc fe80::%E04-Xfinity/64 E04-Xfinity 0
            DAc fe80::%bridge-vlan1/64 bridge-vlan1 0
            [gavron@EhudGW1] /ipv6> /ping 2001:558:4043:16::10
            SEQ HOST SIZE TTL TIME STATUS
            0 no route to host
            1 no route to host
            2 no route to host
            sent=3 received=0 packet-loss=100%

          • If you use a Comcast gateway, I think only Comcast can fix the issue. And I think they’ll fix it for free.

  4. Thanks for an awesome writeup. I have a server for Plex Media Server (and various other things) that uses 4x USB3.1 16TB drives in 2x RAID-1 (one cold spare, not mounted other than during sync) on a Linux server.

    I don’t want to risk data loss using btrfs. Synology uses BTRFS. I don’t want Nx Power Bricks, so a multi-bay device makes sense. SAN, NAS, whatever.

    Can the 1821 be “repurposed” for hardware only, with a regular linux distro, with md sw RAID, and still work? I want the bays, the power supplies, the Ethernet, just not btrfs + homebrew software to control it.

    Any advice appreciated. With a $2K barrier to entry (1821 + drives) this isn’t something I’m just going to go “buy and do” without a hint that success is feasible πŸ˜‰

    Reply
    • I don’t think that’s possible, Ehud. Also, no Linux distro is better than DSM for Synology’s hardware and you can use ext4 instead of Btrfs. Anyhow, it seems you know just enough to be dangerous. πŸ™‚

      Reply

Leave a Comment

πŸ“Œ